• php5.2配置使用memcached(附php_memcache.dll官方下载)

    当前PHP都已经到5.4了,但是我还是5.2,没办法,已经从以前的更新强迫症到现在的更新拖延症了。所以说一下PHP5.2的memcached怎么配置使用。

    这里下载最新的pecl包,即使版本不一样,只需要保证是5.2的即可,如pecl-5.2.6-Win32.zip。然后把压缩包里的php_memcache.dll解压缩到PHP安装目录下的ext文件夹中。

    打开php.ini,在extension列表后加上:

    extension=php_memcache.dll

    打开memcached,使用下面脚本测试memcached和PHP联合是否成功:

    <?php
    	$mem = new Memcache;
    	$mem->connect('localhost', 11211) or die ("Could not connect");
    	
    	$mem->set('test', 'testMem');
    
    	echo $mem->get('test');
    	
    ?>

    OK,就是这样。